Enter your keyword

A old-new blog about random pursuits of a work-from-home mom.

Saturday, March 25, 2017

Globe DSL 1299 10 mbps Plan Review

I haven't posted in a while as I'd like to give some time for the connection to "improve" after upgrading to the new Globe DSL 10 mbps plan 1299. But it looks like there really is something wrong with Globe's DSL connection. Everyday, I'm monitoring the connection via the modem's web GUI (192.168.254.254). The connection is so bad that the modem goes offline (no "internet" light, flickering ADSL LED, and "no sync" in the web GUI) every few minutes. The Upload and Download speed changes from 10 mbps to as low as 1 mbps. Seriously. Here's a screenshot of the "downgraded" speed:


Based on my "research", I found that the modem's connection could be "transferred" to a different modem, without actually having to move the entire line and equipment. A working DSL line, modem, and the email set up in the modem ie [email protected], with the subscriber account number are what anyone needs to get connected. I used a different open-line modem that I bought (Tenda D301 Wireless N300 ADSL2+ Modem Router) and it worked. Now, why am I saying this? The subscriber email and account number isn't actually privy to the subscriber alone, as installers and activations team also know this (don't want to cause any conflict, but I just felt like I had to share this). Well, it's a moot point. You can say that I don't have any proof that "someone else" could actually be using my connection in a different location.  I'm open to discussions. 

I am not 100% sure and like I said, I don't have proof. How could the service be installed if people involved in installing and activating/upgrading do not know how this stuff works?? Right? They had to know. But Globe, there has to be a better way to do this. Modems or anything that has something to do with upgrades have to be pre-configured with the necessary details, without having to disclose them to anyone other than the customer himself. WTH.

-- end of rant

Now, I don't want this post to be just about my issues (even if it's not really just my issues, mind you). I have to give Globe the virtual high-five for their much improved customer service. My husband called (I didn't want to, and I was on shift) their hotline and it's good that they are going to dispatch a tech tomorrow. Today's Saturday, and it's suprising that they're sending out a tech tomorrow, which is a Sunday. Yay! Good job! In case you need something to be sorted out with Globe, I'd still recommend calling their hotline as it looks like Globe has finally "addressed" phone customer support shortcomings.

Prior to contacting Globe customer support by phone, I tried reaching out to them in Twitter. It was of no use. I was advised to cease all activities such as YouTube streaming (I blocked this in the router so it's inaccessible), and torrent downloads (we don't use torrents on any of our devices) then do several speedtests. I know that this is normal protocol (I worked for a U.S. ISP/telco), to ask customer to do basic troubleshooting before they can do anything. But like I said to the Globe Twitter handler, I would not have contacted them in the first place, had I not know what I'm dealing with. It's  not about slow speed, dang it! The connection isn't stable. I just had to stop tweeting (my connection, of course, is preventing me to keep tuned to their tweets) and I have a job (which is online). And that's it for me on Twitter. I won't contact them again on any social media channel. It's just not effective, that I had to ask my husband to call instead. Good thing, the landline is working.

Update: March 26, 2017, 10:00AM

Technician came as advised by the customer service rep. He fiddled with the home phone a bit, listened several times, then checked the modem. After a few minutes, he went out and told us hes going to get a new modem (we were still using the old Prolink H5001NS ADSL2+ Modem/Router that was installed back in 2013).

Apparently, the modem that we were using "cannot handle" the 10mbps download speed (said the tech). The technician then came back after thirty minutes, with a new ZTE H108N ADSL2/ADSL2+ Modem. I was quite surprised, as I already tried a different modem, albeit one that's not provided by Globe. But, okay, he brought in in anyway, so we agreed. 

The connection got better and he told us to just drop by at the office (no need to call customer support) which is, suprisingly, just a stone-throw away from the house. At that time, I wished we'd never really had to do that after he checked on our connection. And so he went. He even called in the afternoon to check on the status and we confirmed it got a lot better.

We were in for a suprise on Monday, though. The connection went off several times (just like before). My husband decided to come by at their office and he was told they'll check in again in the afternoon as the techs/installers are out on field duty. Okay, so pinagtyagaan ko na lang, kahit feeling ko aatakihin na ko sa asar. I use the internet for work, I train people and I can't afford to get disconnected all the time. Ayun na nga, the technician said there's really a problem with the "cabinet" (DSLAM-Digital Subscriber Line Access Multiplexer). We've got no choice but to wait until they got that thing fixed. SMH.

No comments:

Post a Comment